Choosy

Choosy 1.1

Release notes

This version of Choosy requires OS X 10.9 or later.

Features

Bug fixes

Removed features

Download

Choosy 1.1 is no longer the latest version. I strongly recommend you download Choosy 2.2.1 instead.

(If you're really sure you want to download this outdated version, here it is: Download Choosy 1.1.)