Choosy

Choosy 2.2

Release notes

New features

This version of Choosy requires macOS 10.15 (Catalina) or later. For earlier versions of macOS, try Choosy 2.1 instead.

Bug fixes

Download

Download Choosy 2.2.